CyberLink Community Forum
where the experts meet
| Advanced Search >
PowerDirector 16 Unable To Run As Admin
Reply to this topic
DavidB&G [Avatar]
Newbie Private Message Joined: Feb 13, 2018 16:19 Messages: 2 Offline
[Post New]
Hi All,

I've already searched everywhere I can in this forum and on the web, but I can't find a solution to my problem.

I recently got a new laptop with Windows 10 Pro. Same operating system as my last laptop with PD16 on it. I got everything I needed from CyberLink to install on the new laptop, however, even when I "run as administrator", when I open PD16, it opens to the screen asking me to pick a mode, but then tells me that I need admin priveleges to run the software.

I am already logged into an admin account. I tried to create a second account as an admin and "run from another account", but that isn't working either. I have uninstalled and reinstalled and tried it all again.

WaveEditor2 and AudioDirector7 are opening just fine. I was able to register AudioDirector7.

I've even contacted Microsoft, and they've confirmed there is an issue with the software.

Has anyone else had this problem or know what a solution might be?

Thank you!
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team