CyberLink Community Forum
where the experts meet
| Advanced Search >
Waiting for isales.gocyber(etc) is down or?
Reply to this topic
BB Jones Jim [Avatar]
Newbie Private Message Joined: Apr 15, 2013 15:22 Messages: 3 Offline
[Post New]
Wed 1pm Pacific Time.

Trying to reinstall and I have a link and in spite of a terrible temp pw with a font where lower case i's look exactly like (in their font) lower case L's and where there are several i's and L's, I think I finally got the combo right (no security msg), but now on 3 browsers an enless "Waiting for isales.gocyber(etc). ".

Also can't seem to post into support.

Any insight and thanks in advance.

This message was edited 1 time. Last update was at Dec 05. 2018 16:02

Reply
PowerDirector Moderator
Contributor Private Message Location: New Taipei City, Taiwan Joined: Oct 18, 2016 00:25 Messages: 527 Offline
[Post New]
Quote Wed 1pm Pacific Time.

Trying to reinstall and I have a link and in spite of a terrible temp pw with a font where lower case i's look exactly like (in their font) lower case L's and where there are several i's and L's, I think I finally got the combo right (no security msg), but now on 3 browsers an enless "Waiting for isales.gocyber(etc). ".

Also can't seem to post into support.

Any insight and thanks in advance.



Hi,

If the download link continues to fail, please contact Customer Support and post the CS Ticket No. back here and we can try and follow it through.

Cheers
PowerDirector Moderator


For customer support related issues, please contact:
- Customer service: https://membership.cyberlink.com/support/customer-services.do
- Technical support: https://membership.cyberlink.com/support/service/technical-support.do
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team