CyberLink Community Forum
where the experts meet
| Advanced Search >
Can't install Media Suite 10 on MAC
Reply to this topic
JeanW [Avatar]
Newbie Private Message Joined: Jan 18, 2018 20:10 Messages: 1 Offline
[Post New]
Bought an LG DVD Writer SP80 that came with Cyberlink Media Suite 10. Box says MAC Compatible. When i put the disc in the tray, it spins up but never launches the installation process. Have tried several times to contact Customer Support but no luck.
Will this program work with a MAC running OS X El Capitan?
Reply
CLD [Avatar]
Senior Contributor Private Message Joined: Mar 23, 2007 02:05 Messages: 925 Offline
[Post New]
Hello,

No. All the software on Media Suite 10 is for Windows PC only.

David
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4627 Online
[Post New]
DVD Writer is compatible in case you are wondering. .
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
variable [Avatar]
Newbie Private Message Joined: Nov 17, 2018 15:57 Messages: 1 Offline
[Post New]
Quote DVD Writer is compatible in case you are wondering.


Hello,
I have bought the same package for the MAC. The only software in the box apparently is for windows only despite the box saying the contents will work on the Apple. What do I do now to get the sofwtare that I paid for to run blue-rays on the Apple?
Reply
optodata
Senior Contributor Private Message Location: California, USA Joined: Sep 16, 2011 16:04 Messages: 3975 Online
[Post New]
I haven't seen a boxed version, but the Media Suite download page only lists Windows:


You can run most Windows programs on newer Macs, but you need to use one of these methods. Also, the current version of Media Suite is 16. Did you mean to type that, or did someone actually sell you a copy of version 10 (which was released back in 2012)?
youtube/optodata

DS365 | Win10 Pro | 8 Core/16T i9-9900K (4.8GHz) | RTX 2070 | 32GB RAM | 6TB SSDs

Canon Vixia GX10 (4K 60p) | HF G30 (HD 60p) | HF S200 (HD 30p) | Yi Action+ 4K | 360Fly 4K 360°
Reply
CLD [Avatar]
Senior Contributor Private Message Joined: Mar 23, 2007 02:05 Messages: 925 Offline
[Post New]
Quote


Hello,
I have bought the same package for the MAC. The only software in the box apparently is for windows only despite the box saying the contents will work on the Apple. What do I do now to get the sofwtare that I paid for to run blue-rays on the Apple?


Hello,

I would assume for both of you that the wording on "the box" is on the package the LG drive came in. I would think LG was referring to the LG drive works for Mac, not everything in the box, i.e. the software. If I a wrong, please share a photo from the package where it says the software works on Mac.

All CyberLink software is for PC only, except PhotoDirector when it is bought as a stand alone product. As Optodata showed you, all suite software is for PC as well.

If you are looking for software you "paid for", you should actually be contacting LG about this.

Good luck
David
Reply
EconomistAnyone22 [Avatar]
Newbie Private Message Joined: Oct 28, 2019 09:12 Messages: 1 Offline
[Post New]
Quote


Hello,

I would assume for both of you that the wording on "the box" is on the package the LG drive came in. I would think LG was referring to the LG drive works for Mac, not everything in the box, i.e. the software. If I a wrong, please share a photo from the package where it says the software works on Mac.

All CyberLink software is for PC only, except PhotoDirector when it is bought as a stand alone product. As Optodata showed you, all suite software is for PC as well.

If you are looking for software you "paid for", you should actually be contacting LG about this.

Good luck
David


It would appear that I've made the same problem then as OP, if this is the case, would you recommend any specific software to use this device on mac? I'm going to google a bit maybe LG has something.
Reply
stevek
Senior Contributor Private Message Location: Houston, Texas USA Joined: Jan 25, 2011 12:18 Messages: 4627 Online
[Post New]
For MAC (ios) users Go here and scroll down to see the Moobile Applicationsproducts that are compatible with the latest version of IOS )as noted on that page).

This message was edited 1 time. Last update was at Oct 28. 2019 13:00

.
.
BoilerPlate: To posters who ask for help -- it is nice to thank the volunteers who try to answer your questions !
Anything I post unless stated with a reference is my personal opinion.
Reply
Reply to this topic
Powered by JForum 2.1.8 © JForum Team